Solidity doesn’t occur while offender is moving via “move”



  • Both objects are walls, both are solid. Offending object is custom “joystick” controlled, and passes straight through the stasis wall. Object boundary changes from blue to yellow.



  • @thecheater887 Not sure if this is a bug, pretty sure only physics joystick controlled objects are supposed to be stopped by walls. But maybe it would be useful on wall objects for the different way it moves.



  • @aidan-oxley what’s even the difference between physics and wall other than gravity or air resistance extra calculations? I literally want an object not affected by anything but the joystick.



  • @thecheater887 Push the joystick on a physics object or wall object, both of them will move, let go of the joystick on a physics object, it'll keep going until it hits something or air resistance slows it down, let go on a wall object and it'll stop instantly. A wall object will go through walls using joystick controls, but a physics object will run into walls.



  • @aidan-oxley so make it physics and if stopped touching the joystick set velocity 0? Got it.



  • @thecheater887 if you want it to (almost) not be affected by other physics objects you can set the mass really high.



  • What about making a physics object not morph into then repel away from a wall object? As there’s no “get passable”.



  • @thecheater887 I think that's hyperPad's squishy physics.


  • Admin

    Are you using Joystick Controlled on a wall object? If so, then yeah.... that won't work too well. It's not. really a bug, it's just not designed to be used that way.

    Joystick controlled is an override, where it sort of does a lot of things for you and takes a bunch of assumptions. Like your object being a physics object.

    As for the difference between wall and physics: https://hyperpad.zendesk.com/hc/en-us/articles/202509515-Physics-Modes

    Things get a bit weird when two wall objects collide, because well.... they shouldn't be colliding. Your wall objects should typically be stationary. Since, you know... They're a wall.



  • @murtaza I’m not actually using joystick controlled. Here’s a project showing my issue.

    Project code is confusing (I code as I think. Can you tell how my brain organizes thoughts?), so I’ll attempt to explain. In the red reticule, there is the offending logic. The way it works is it takes the players touch, checks where the player touched last frame, then checks if it is different enough to change where the character is going. None of that matters for this, but it’s jittery as hell, so, I’m open to suggestions.

    Anyways, if you look at the set velocity in the reticule object, then at the collisions and properties of the mutant (it doesn’t qualify as a human.. my graphics skill shows!) and the terrain.

    My intended effect is something like in RTS games (Diablo, Mario Superstar series, Shadowrun series, Sims) where walls are an absolute barrier. Clunk. I don’t want my mutant to phase into the wall, then be repelled out, if possible.

    I’m certain I’m doing something wrong, but if the morphing isn’t a bug, I’d like to figure out how to work around it.



  • Any ideas as to how to stop that gravitational force?


  • Admin

    I haven't had a chance to check the project out yet.

    But I can't quite understand what you're saying the issue is. In the global properties we have 2 settings, physics refresh rate, and physics iterations. These basically calculate how much physics calculations happen, and determine the "precision". This can remove that "jelly" like feeling. But it does come at a performance cost.