Frame Rate Slow Down...

  • For reasons unknown, the frame rate started to stutter. I just spent a few hours trying to remove things, turn things on and off and do all sorts of other changes to my projects in a mad pursuit of this.

    But it's not me. It's you.

    After a restart of the app, and then a second restart. Surely getting it all out of RAM, everything returned to its silky smooth normal.

    Which brings up a second point.


  • I believe this has something to do with the particle editor.

    If I don't use the particle editor, this doesn't happen.

    If I do, it does.

    There might be other things leaking and doing weird things, but this is definitely one of them.

  • @Deeeds Try going into particle editor, and reselect EVERY SINGLE particle’s graphics. I’m not sure if hyperPad fixed this or not in the last update. Also lagging obviously depends on what your project is doing, having lots of particles playing on lots of objects and the particles having a high count would obviously get laggy.

  • @Aidan-Oxley This isn’t about the number of particles, much as I thought it might be.

    I hadn’t changed anything from one build to the next, but it began lagging. Which sent me on an infinite search for the problem, right back to a base project. At which point I decided I was not the problem..

  • Admin

    Are you using a custom particle image? If so how large is the image?

  • @Murtaza I'll say this one more time:

    Fine one moment. For a week. No changes.

    Then slow downs, stammers and dropped frames that have nothing to do with my particle settings, but everything to do with leakage and issues in the particle engine.

  • @Murtaza Take this as gospel: I got it down to almost NOTHING in the scene, and still having the same frame rate issues.

    Look at this part of my first post, and believe it, please:

    " I just spent a few hours trying to remove things, turn things on and off and do all sorts of other changes to my projects in a mad pursuit of this.

    But it's not me. It's you."

  • @Deeeds Could you link your project? I wanna have a look because I’ve had laggy particle problems before but o fixed them.

  • @Murtaza This is what a frame drop looks like. See the ring that's brighter and has a little gap behind it where one ring is missing.

    Thanks to the fact that your particle engine doesn't interpolate particle positions in between frames, I can overload it to more accurately monitor frame rates than the shitfulness that is the cocos2D frame rate reporter.

    This is from a few days ago, and is about the only frame drop in 30 seconds of testing, whilst concurrently piping the whole screen through lightning cable to the Mac to record it. So it's probably a bunch of system calls that caused it.

    Soon after this, all hell broke loose and your engine became so laggy that it was incredible. Not just in play testing, but also in editing behaviours and scenes. I was frantically deleting scenes, particle systems and all sorts of objects and behaviours, mistakenly thinking it must be something I did.

    By the time I got to a scene with nothing more than the hero, ground and camera controller, and it was still stuttering away, I realised the problem wasn't me.

    0_1510459361034_Screen Shot 2017-11-12 at 11.56.48 AM.jpg

  • @Aidan-Oxley No, I cannot upload the project.

    As I've said before: Force quitting the app TWICE fixes the problem. For a while. It slowly creeps back. At which point I either force quit a couple more times or do a hard reset of the device, which works even better. Then I can tinker for an hour or so before lag starts to creep in.

  • @Deeeds Yes! I get this all the time, the inconsistency in particle trails. Even when my project isn’t lagging, every now and then my particle trail will break a bit and have that effect in your screenshot above.

  • @Aidan-Oxley This is from system calls. It's much more noticeable in a particle system that doesn't interpolate than one that does.

    iOS system calls don't care about games or anything else, they just do whatever they want. Check networks, search for app updates, check the cell connections, report home... etc etc... they all get priority, and that's the little flutters you see, even in the most primitive of scenes.

  • @Aidan-Oxley But when it becomes consistent, and a reliable LAG festival, that's either too much going on, or the game engine leaking and chugging on itself. hyperPad has some issues with editing particles frequently. It does not like it. And it doesn't like a lot of positional changes of scene items, either.

  • @Deeeds Oh I see. I don’t have lag buildup over time then because I usually don’t work on projects for more than an hour at a time.

  • @Deeeds How many times did you change particle settings before it got super laggy? I know that particles are weird in that they want you to restart hyperPad to update the effects of the particle. Otherwise you’ll find a glitchy duplicate of the particle (the old version) that disappears after restarting).

  • @Aidan-Oxley Please look at all of what I'm saying, not the low hanging fruit you can use to deny the problem. It will literally happen to you at the point where the particle system or leak occurs in the things you do, regardless of how long you're using the app. I haven't isolated anything other than large numbers of object movements in the scene and large numbers of particle editor changes that cause the problem. The amount of time is a function of me getting to that part of what I'm doing and not otherwise important.

    I get that you're overly fond of this app. But it DOES HAVE PROBLEMS!

  • @Deeeds I know hyperPad has problems. I’m just trying to help you see if there’s ANY way at all to make this better without resorting to ONLY waiting for hyperPad to fix it.

  • @Aidan-Oxley Share your success stories.

    Force quitting the app, twice, and hard resets are what I've found to work.

    What have you found helps?

  • @Deeeds The only times I can remember what my whole project got laggy, including the editor, is when my project has too many objects.

  • @Aidan-Oxley So why the comments about reselecting particle materials?

Log in to reply