"Your hyperPad is out of date" when it isn't