Sound Volume Set Input Field



  • In the screenshot below, the Set Input field of the Pipa sound is not being updated (the volume field). The sound was dragged to the scene.0_1488038596505_IMG_1892.PNG


  • Admin

    On my phone. So I can't see the picture clearly right now.

    But you need to make sure to trigger the sound behaviour again. It's not a realtime dynamic audio control.



  • @Murtaza So what does it mean in the alert where it says it allows you to change the input "on the fly?"

    How is it intended to be used?


  • Admin

    @TutorialDoctor in the case of audio, the volume is only affected next time it's executed.

    I believe it's a limitation of the audio engine. @hamed would know more though.



  • @Murtaza @Hamed Following up on this. Is there a way to change volume on the fly? Trying to have the music fade out instead of cut off abruptly.


  • Admin

    Set a timer at an interval for how smooth you want to fade out the audio. (the smaller the smoother it is).

    Have a box container representing how much volume there is.

    Subtract the box container value by some small amount every iteration of the timer, lets use the same interval as the timer.

    Set the set input field of the audio volume to be the box container value and make sure restart behaviour is called.

    Disable the timer when the box container value is < 0.



  • @Hamed The issue is that the sound keeps getting triggered on each restart. Although the volume does go down each restart. If there were some sort of set_volume behavior that may work. Or I guess, what do you mean by setting the input field of the audio volume? Don't use a Play Sound behavior?


Log in to reply