Arrays Don't like Negative Numbers



  • I think they're treating them as strings, but can't be sure.



  • @Deeeds what exactly don't they like about negative numbers? I've used negative values in arrays loads of times.



  • @Jack8680 They refuse to use them, and are now not working at all, for any values, so I think it's converted the whole array into strings.



  • @Deeeds arrays work fine as strings for what I've used them for. If you send the broken project or a part of it I can take a look.



  • @Jack8680 I'm not sending my project. There is no need. I don't need strings. I need negative values.



  • @Deeeds I don't know if anyone can help then. I can run array behaviours on an array in string form, e.g. get array value of ["-1","-2"], or even of [-1,-2] works fine for me.



  • @Jack8680 What? I'm not trying to find negative locations. I'm trying to store negative numbers in the array, and use them for positions. When doing this, it didn't work. I rebuilt the array, after a restart etc... and after the referencing weirdness, and they worked with negative numbers.

    So it's a cycle of bugs that caused this pain.

    Also have a massive visual stutter going on in gameplay that's new, and can't be there because nothing has changed. So something is amiss in the app.



  • @Deeeds I wasn't finding negative locations, those were two arrays storing negative numbers, in string format. I've never had this bug or the referencing bug, and I can't reproduce them.

    I can understand if you don't want to send your project but it's hard to figure out a bug like this. So did the restarting fix the referencing bug or are you still able to reproduce it?



  • @Jack8680 It happened, I repeated it, and I don't want to spend my life sourcing and proving bugs for something I'm not an owner of, so I moved onto things that do work. And continue to progress.

    I've enough experience with these matters to know not to waste my time doing QA for others for free.

    I also saw, in the last hour:

    1. Tabbing whilst entering numbers into array causes random jumps back through the list at certain points, so if you don't watch what's happening you'll wind up writing over previously entered numbers.

    2. A random jump like above that went to the name of the array, not one of the indexed values

    3. A complete crash of hyperPad when trying to delete the last of an array

    4. Stalls whilst trying to delete array entries from the bottom of the list

    5. Spawning producing more than the limit of items

    6. Spawning completely stop working from one run to the next with NOTHING changed.

    7. Performance drops in the editor whilst working on this



  • @Deeeds It would be so much easier if you just gave links to your projects! Then someone more experienced with hyperPad can take a look to see what’s going wrong. Even if you just reproduce whatever you’re talking about in a random test project, pasting a link onto the forums doesn’t take very long and it’s heaps easier than trying to explain with text. Negative values work fine in arrays for me.



  • @Aidan-Oxley OR... You could trust me that these things are happening, the way I'm saying they're happening.

    On the weight of averages, much of what I've said you've seen is true. Assume the rest is, too It will help me not want to snap when you say "not happening for me...." for the hundredth time.



  • @Deeeds if you are not willing to post a test project showing what’s wrong, and no one else can reproduce it, how the heck are they supposed to fix it? At last without spending a lot of time. Which means your hundred other bugs will have to wait to be fixed.

    @Deeeds said in Arrays Don't like Negative Numbers:

    @Jack8680 It happened, I repeated it, and I don't want to spend my life sourcing and proving bugs for something I'm not an owner of, so I moved onto things that do work. And continue to progress.

    I've enough experience with these matters to know not to waste my time doing QA for others for free.

    Sure you don’t own the app, but as a user if you want it better you have to do your part.
    And it looks more like others( @Jack8680 and @Aidan-Oxley) are wasting THEIR time doing QA for you.
    You’ve got complaining down to a fine art, but don’t seem willing to help fix things.



  • @iTap-Development I don't need them to do QA for me. They can stop at: doesn't happen for me, has never happened for me, have always seen this, or "never tried this".

    Anything more isn't their problem. I'm not posting these things for their benefit, NOR FOR MINE!!!!



  • @iTap-Development this is the bug report part of the "forum", I don't expect or ask that ANYONE other than Hamad look at these. Suggesting that it might be something in my project when I've ALREADY isolated that possibility is just ridiculous. Yes, they and you are wasting your time if you want to inspect my projects to prove I'm wrong on your install on your iOS version on your device. It's what I'm seeing and I've isolated it, reproduced it and become certain of it.

    AND THEN I've decided it's probably a sufficiently annoying problem that Hamad should know about it and there should be some public record of it incase someone else ever has the same problem.

    THAT IS WHY I AM POSTING THESE THINGS HERE!

    I thought the above would be obvious.



  • @administrators @iTap-Development @Aidan-Oxley @Jack8680

    These are nowhere near all the bugs and problems I'm seeing. These are only the ones I can be bothered signposting for future users and think sufficiently troubling that even an overworked and grossly underpaid (and isolated) @Hamed
    should know about and put somewhere on his near infinite todo list.

    Thank you all for your consideration.

    Posting "I'm not seeing this..." is sufficient. It means your device, your iOS version and your install of hyperPad aren't having this problem. Don't trouble yourselves further with bugs.

    If I have problems, queries and need help and suggestions I won't be posting those sorts of things here... they'll be in the forum section appropriate for that.



  • @Deeeds but someone more experienced may be able to find something that you didn’t notice that could be causing the “bug”.
    A simple example https://forum.hyperpad.com/topic/633/spawn-on-object-also-has-area/2
    Murtaza, more experienced, was able to show you that there was a logical explanation.


  • Admin

    Deeds, the point they're trying to make is it could be a logic error and not actually a bug with hyperPad.

    We find that most "bugs" are in fact user error.



  • @Murtaza I have isolated for that by the time I'm posting here. And already spent more time reporting on undocumented and annoying issues than anyone else seems to have in the short time I've been using your app.

    It has been enough of an act of sharing to bother this much, with this many things that I think will likely cause stumbles for other new users.

    NONE of you seem to understand the plight facing new users of this app because you're all incredibly familiar with it,. Further, and let's be really honest, you're all largely unfamiliar with the expectations and experiences of others. You always speak of your own anecdotal experiences in isolation, as though they're gospel. But the most annoying this is the blind defence and love of this app to the exclusion of understanding what else has been considered and done by others thinking about the same kinds of problems in other environments.

    Most of these problems of coding visually were solved in the 1960's, and then lost.

    AGAIN: I have isolated those things I report as bugs in behaviour. I have proved them to myself more than once, and found workarounds and "fixes" before I file them as bugs.



  • @Deeeds you proved them to yourself? Congratulations! You’ve completed the first step....now you need to prove it to the devs!



  • @iTap-Development The case you're pointing at, let me point to the documentation in the information panel that informs me of what this does:

    word for word, from Spawn on Object:

    Spawn Area
    The area within your running scene you want your object to spawn in. The larger the area, the more random you can make the spawn.

    That doesn't sound like the functionality that @Murtaza is describing, does it? No... because it's NOT what he's describing. This is the exact same definition one finds in Spawn on Area.

    Word for word...

    How might I be expected to perceive that it's NOT the same thing?

    So it's a bug in the documentation?

    I've already found a few other bugs in the documentation, like the lack of animation between setting graphics changes... it's in the documentation but not in the functionality.

    I can't be expected to read the minds of the creators. And won't be spending time making special demo samples of EVERY single farking bug, inconsistency, issue etc I find. That's more than a fulltime job.

    Again, look up, see the list of remembered issues I faced yesterday in one hour... that wasn't all of them, just the ones pertinent to arrays at the time.


Log in to reply
 

Looks like your connection to hyperPad Forum was lost, please wait while we try to reconnect.