Annoying bugs with particles

  • There are probably heaps of bugs with particles, like how if you set time scale to something negative particles start to grow huge. But here are 2 that have been annoying me in particular, shown in this project:

    When the particle is turned off by a behaviour (set in this project to happen after 13 seconds), the last few particles will be placed in the top right corner of the object (so like 100%x 100%y anchor). I don’t know how I never noticed this until now. Also so,etching annoying, especially for smooth particles like the one in this project, is that they aren’t smooth! Kind of wanting a particle for every frame since the object is moving every frame, but the particles keep missing a frame.

    Here’s what you should see by the way when the particles are turned off:
    It should just be a single circle

  • @aidan-oxley I've seen a very similar "spawning" point for particles, behaving much the same as you're describing when turning them off. It's not in the top right for me, instead it's at the left edge of the default scene starting camera location, regardless of where the camera actually is at.

    And, yes, all the issues of failed interpolation, too.

Log in to reply